Align Position freezing/"anchoring" the object for seemingly no reason

I’m working on a client sided VR cave and for some unknown reason align position freezes/“anchors” the part after a couple seconds.
This happens no matter if the align position is server or client sided.

This issue suddenly appeared on the 4th of may even though the day before this never happened.
I know I had to update my roblox studio so there is a good chance that this is a physics optimization Roblox made and they might’ve overlooked align position.

I have looked online but no one seems to have had this issue. (Unless I’m blind or something)
I have no idea what I could do as a work around as moving the part using a script doesn’t seem to reactivate it like in the video.
And yes I have triple checked if the part get it’s anchored property set to true, it does not.

I’m happy to provide additional information if needed.
Any suggestions for fixes are much appreciated!

Are you making sure it has a network owner? Otherwise you could try smth like RigidityEnabled but that probably wouldnt give desired results.

I haven’t really worked with network ownership but wouldn’t something that is client sided always have the owner of the client?
My game will be designed to be singleplayer so I don’t think network ownership will help much with that but I don’t know.
I’ll have to see tomorrow if it would be able to help at all.

I think if the part is client sided then yes. However you need to manually do it on server if its global.

Good luck and update me on what happens.

Sorry for the late response, I wasn’t able to work on it for a week.
I tried using network ownership but I wasn’t able to figure it out.
Besides that I did notice that it only froze for parts where the parts where it’s supposed to move to is anchored so I just unanchored it.
For my script I move the part at every frame so I just used to that to set the AssemblyLiniearVelocity to 0 but other people could possibly weld an unanchored part to the anchored part and attach the align position to that.
I’m unsure if I should mark this as the solution because it’s technically just a work around and I’m unsure if the welding thing works.
Thank you for trying to help me though!

I have this problem too. Seems more like an engine bug then an error with your code. I am making a grab system and this bug occurs for every part in a welded model