All CoreGui Disabled

It’s happened to me multiple times. For me, it usually happens when I teleport to another game from inside a game.

Same here, but it never loads. Not sure exactly what’s causing it as it never loads and not even re-installing roblox did anything. [ Update: I managed to get it working, randomly loaded about 5 / 6 minutes after joining a roblox game, it still doesn’t load in studio though. ]

1 Like

Noticed this too, it loads after a while, but it takes from 1 minute to 5 minutes, also F9 for console does not work either while it is loading, happens both in-game and in studio. Only coregui that loads immediately is chatgui.

I first experienced this problem occasionally and as of just now, it has become much more frequent, now occurring after every server I am in. On rare cases, it will load it all within 5 minutes but often will never load it.

However, my chat was still available to me while the other core GUIs did not appear.

1 Like

14 posts were split to a new topic: Feedback - Replying to Bug Reports

This is happening to me now, rejoining is not fixing it and it’s in a game im working on. I’m also experiencing high latency during input to response the response time is like 0.35 seconds

EDIT: Pressing F9 alot seems to fix it.

It’s gotten worse for me, my graphics level is now stuck at one and takes 1-5 minutes to automatically go up to 10. The CoreGui is disabled so I can’t manually make it go up.

It’s on 10 by default (since I’ve had it on that for a long time) but when I join games it slowly makes its way up to level 10 graphics, starting at 1.

Just had the same issue, I had to rewrite some code that used TopBarEnabled events. This is pretty infuriating because my game with a decent player base just broke from an update while I was sleeping.

It definitely reached my project. I verified that the issue had nothing to do with my game’s loading system after removing the pcall load function (That checks to see if the StarterGui service has loaded) and seeing that it loads after removal - though the topbar is Still missing implying that it didn’t load at all.


Also happening to the game title

Scratch that - The game does indeed load in the CoreGui Elements, although at a sluggish rate. :confused:

1 Like

I was able to fix the issue pretty quickly, I’m not too worried about the player base. Are you not able to fix it for your game?

1 Like

How did you fix it? I just disable all code that referred the coregui.

I think it depends on what specific CoreGui elements you’re calling for crucial functions in the game. For me, it was TopBarEnabled, I had an event to check if it was in studio or not so it would enable accordingly. Idk what your issue is but taking a look at the dev console should show you.

I just disabled top bar with this:

game.StarterGui:SetCore("TopbarEnabled", false)

Worked for my game for 2 years. Guess that isn’t reliable anymore.

1 Like

I’m currently having the same issue. To add on every Roblox Studio/Game I join/test lacks a topbar, and a menu, I also reinstalled Roblox, and even with a fresh installation, I am still having the issue. Hope this gets fixed soon, was working on a cool project.

EDIT: Seems to be half resolved, now it comes back after about ~1-10 seconds of starting the client

2 Likes