All CoreGui Disabled

This is a pretty quick report, since I don’t really have much to say about it, but it is worth reporting.

I just joined an empty baseplate game, and all of my CoreGui was disabled.
Not just the script-accessible ones - I couldn’t even open the Esc menu. The only remaining parts were the actual chat window which worked as usual, and a small black bar in the top right where the leaderboard was supposed to be. The topbar and Roblox icons were totally missing.
This place had no scripts at all. I also couldn’t open the developer console to check for any errors, since that was also disabled.


Upon rejoining everything behaved as normal:

EDIT: System information:
CPU: Coffee Lake Intel Core i5 8600k @ 3.6GHz
Motherboard: Gigabyte Z370 AORUS Ultra Gaming-CF
Memory: Dual channel 16BG DDR4 @ 3600MHz
GPU: GeForce GTX 1080 Ti
OS: Windows 10 - Build 18363
Roblox version: ? (how do I check this lol)


It should be a Corruption in Roblox gui files re-install may fix

1 Like

Simply rejoining the place fixed it. This is the first time it’s happened to me.

A post was merged into an existing topic: Feedback - Replying to Bug Reports

You should add repro links/steps or system details, this is not really actionable for engineers at the moment.


Just so it doesn’t happen again, make sure all of your CoreUis are enabled by opening a LocalScript in ServerScriptService and putting

local StarterGui = game:GetService("StarterGui")
StarterGui:SetCoreGuiEnabled(Enum.CoreGuiType.All, true)

There weren’t really any repro steps, as I said I literally joined the place and it was all missing. I can include details of my system and Roblox version though, that might be wise…

1 Like

As I said, this isn’t an issue with CoreGui being disabled by a script. The place was an empty baseplate, and more GUI was disabled than is supposed to be possible. Very curious.

1 Like

I can give link the place file that this happened in, but it’s literally just a baseplate with a single part added and a surfacegui on it. Can’t imagine it’s specific to the place.

This happened to me once or twice on mobile, didn’t know computers also had this problem.

Either way, just to force all CGui to be enabled…

I reported this a while back. The issue probably wasn’t fully resolved ?
CC: @TheGamer101

This would happen most of the time on prison life. I thought it was just some really weird exploit since prison life is infested with exploiters but there isn’t a way to disable the menu button.

So I can confirm this happens to me. Happens like what 5-10% of the time.

Also experienced about <2 days ago or so on another game.

Happened to me too some days ago. If I remember correctly it was also taking longer than normal to load. Does that help?

This happens for me also. But instead of just one game, it happens in almost all the games I play.

It also happened to me yesterday.

I can relate to this.

I cannot go a single without the leaderboard, chat, or escape menu not being available to me to use.
Rarely it works though.

I had this happen to me yesterday on the Windows 10 roblox client.

Same Here,
When you join a game or place the CoreGui would be Disabled for a Min or Sec and then it would appear. This happened a lot For me.

Can confirm this happens to me occasionally no matter what game it is. Probably around 20-30% chance when i join a game itll be disabled like you showed above and i have to rejoin. Hitting escape or F9 doesnt work either so it must be something major