All my script resetted to a older Version and lost every progress

So i was about to start “finally” creating my game I have been working on. I already scripted some Game Mechanics 2 Months ago. Obviously i published it MANY MANY times in this long time span. Suddenly my scripts/modules i did for the main Game Mechanic got “resetted”. One says “print(“Hello World”)” and the other one says "local Players = game:GetService(“Players”). The Modules are EMPTY and everything i did in it is GONE. I checked 2 Month worth of old Place Versions. All of them feature the “new” broken scripts without any script history. All GONE!

So what do i do now?

Expected behavior

I expect to open my scripts without DELETING THEIR WHOLE HISTORY… like how can this even happen.

1 Like

Scripts don’t just reset on their own without a reason. Check these things out:

  • Place version history - did you accidentally revert or overwrite with an old version? Can you download an older version and see if these scripts come back?
  • “Drafts” - does your place have collaborative editing enabled? If so, any changes aren’t active until you submit their drafts manually
  • Plugins - have you given any plugins permission to manage game scripts? There could’ve been a problem with one of them wiping contents from your script whether accidentally or maliciously

Place Version History: Every Old Place Version that had the scripts with content are 99% wiped

The Drafts are EMPTY

And no Plugin is enabled that can manage scripts.

Me personally i got confused cause i know nothing can reset on its own. But there is no way the scripts got wiped on old Versions too?

1 Like

Is it all scripts, or only a few?

These are simple checks, but you didn’t mention if you tried them already:

  • Do you have other developers working on the game who may have deleted or changed the scripts?
  • Have you tried just closing Studio without saving and reopening the game to see if it was a temporary glitch?
  • Do you have the most recent version saved to your computer that you can publish? I have auto-save turned on in my Studio settings, but I’ve got in the habit of saving a copy on my PC every time I publish changes to Roblox.
  • As @Zivao said, any new plugins or free models added may have scripts that delete the contents of your scripts.
  • Im solo developing this game without anyone having permission to join the team create session
  • I just tried to restart studio but still wiped scripts
  • I never saved files like that on my pc after sessions, but i definetly will by now :rofl:

I guess ill script this again. It is probably faster and more efficient. Glad that these scripts didnt had TONS of content in them. Mistakes are made to learn from them.

Could be a Pop Up about Commit Scripts and i didnt read and just clicked the wrong thing.

But if this is even possible a thing to not even the any “Script History” with not commiting but SAVING is crazy to me

This possibly won’t be helpful at all so don’t get your hopes up, but Roblox Studio has an auto-save folder which should be in This PC > Documents in a folder named “ROBLOX”. You could try look in there to see if any place versions with your scripts are in it.

1 Like

Welp… uncommited scripts are LOCAL! Which means when you get yourself a new pc… It will be GONE! Glad that my new PC is only a week old and my old one was under my Desk! I got the SCRIPTS now and will never forget to COMMIT.

Haha had to clear this mess up sorry guys. Maybe this “mistake” will help someone by accident for future records.


I hadn’t heard of uncommitted scripts before.
I almost always Publish to Roblox and then Save to File. When I open up Studio I open up the published version to work on something.

It happens when you enable collaborative editing. It basically allows you to save drafts of scripts and allows you to publish your game without these drafts being “committed”. Once you commit the script it’ll then update it completely so the next time you publish, the changes will show. Drafts are local until you commit them.

Article below explains this.

Personally I have this disabled. I find it annoying to have to commit all my scripts manually.


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.