All my UIs now look like squiggles

Edit: This has suddenly become a problem again D:

Like, every game I join. It’s fine for a few seconds then BAM squiggly. I’m on Mac OS Sierra.

1 Like

Do you know when this started happening?

I experienced this issue with my HTC Vive a few months ago.

I was running Windows 10, GTX 970.

Today. I have super slow wifi and I noticed it typically starts happening when more of the map has loaded in.

At the game I was testing, it happened when the map was spawned in repeatedly.

I’m not sure if related, but the symptoms seem somewhat similar, so I’ll just link to it just in case:

That one has been happening for a while longer though

I have reinstalled Roblox, and it’s no good, and the game I’m working on is pretty much unplayable without the UI.

can you link the game?


Under development right now, and you need 2 people minimum to play

hmm I having a hard time reproducing this issue… so a few questions.

  1. Are you windowed or full screen?
  2. Are you changing the size of your window when this happens?
  3. Are you forcing discrete graphics?
  4. Are you forcing integrated graphics?
  5. Anything else out of the ordinary that you can think of?

Step by step repro steps may help as well.

Just in case you misunderstood, OP said this was a client issue they had on all games, not a problem with their place.

yep, just saw that… either way I can’t seem to repro on my very similar specced Mac unfortunately

It’s full screen. I’m not changing the size of my window. I have no clue you could even force discrete or integrated graphics, and fairly sure Roblox wouldn’t allow it.

I logged out of everything to ensure my GPU wasn’t overworked or what ever. I then joined my test place with a friend. Was all fine until the map spawned in then bam, terrible fragmentation

Hi @DeepBlueNoSpace, please try again now. We’ve disabled a feature which was most likely causing this problem.


Oh wow, that worked great! Thanks so much!

Has this been re-enabled? It has started to happen again.

Can you check if this happens on integrated GPU, dedicated GPU or both?

You can download gfxCardStatus from here which will let you switch between these.

Also, does your MBP have an external monitor attached?

Also, does this happen in Studio as well?

No external monitors. Downloaded gfxCardStatus on my results are as followed. I am testing in studio only.

I’ll update this list as I go through the 3 options.

Discrete only: Happened when I opened a scroll frame with a lot of elements

Intergrated only: Couldn’t get anything to happen, I shock the scroll frame with ~100 images and 300 elements very violently and it worked fine.

Dynamic switching: Scroll frame broke it again. I checked to see which card was in use and it was the Radeon.

Would it be possible for you to PM me the place file and the repro steps (such as “open the place, Play Solo, click this button, etc.”)?