An Unknown Error Occurred when in-putting Account PIN

Not sure if this is appropriate for this forum, but currently no matter what PIN number I put on my account, it tells me that “An Unknown Error Occurred”.

I’ve done some research on this, and seen that people fixed it by it fixing itself or contacting roblox support to remove the account PIN for them.

I contacted roblox support, and they removed the account PIN for me. When I added it back, though, it did the exact same thing as before. Yes I am 110% sure I in-putted the correct PIN for both the setup and the unlock, yet it still does this. I want to know if there is any way to fix this before just completely removing my account PIN for good.

Also, when it pops up with the message, it removes the account PIN slider setting.
This also happens when you in-put ANY number, whether it be my correct pin or a wrong one.

If this helps at all, here are a couple screenshots.


If anyone knows anything about this, please reply!

3 Likes

The front-facing errors usually don’t provide any information to be useful, unfortunately.

If you open the developer console, (F12 on most browsers), go to the network tab and, while it is ‘recording’, try to enter the pin. It should cause an item to appear in the network list, highlighted in red. If you click it, then go to response or preview or anywhere in it really, you should be able to find a more specific error than just an error occured.

1 Like

Hey! I did this, and I’m still not exactly sure what the issue is. I guess roblox just really doesn’t want me to unlock my PIN?
image

Here’s what it says, and it’s not exactly descriptive me thinks.

I would really like if others chimed in on this, and gave their possible solutions even if it may be a dead end.

1 Like

Gonna bump this post for now, still haven’t found a fix

1 Like

I have this issue too, I just contacted Roblox support in hopes to get my pin removed because of this issue. I think for everyone it says “Unable to authenticate request.” when checking the browser’s network tab.

1 Like

They responded to me saying I have to fill out the support from the support form. Which I did the first time :expressionless:

1 Like

It might be related to account switching. Fully logging out of the account and signing back in works for me.

1 Like

Heyo! Figured it out.

I was having the same problem, and I figured it probably has something to do with Roblox wanting to push the application over the web browser. If you attempt to input the pin on the web-browser of Roblox, it gives you the error. However, if you go through the Roblox application to input your pin, it works fine and dandy.

Hopes this helps!

5 Likes

Pretty poor user experience design by roblox right there…

2 Likes

…This actually works, that’s insane. Thank you so much!

If you’re still having this issue, a solution was found by naeeko!