Anchored Part randomly disappearing when played/ran

I was making a map with a neon part but whenever I press play it disappears and I tried using the Run option to find the problem but it just disappears randomly

I am not a builder but this maybe a error on my side or it might be an engine bug or something else entirely.


I have been troubled by this bug so much

its just a guess but the part may be on the very bottom of the map. when any part is under a certain height (y axis i suppose) regardless whether its anchored or not, it gets destroyed. since its a floating map without the baseplate for height reference i suggest placing the parts at a y-axis of 0.5 and not anything lower.

1 Like

Can you send the place file?

I am now encountering the same issue with my game as well.

Maybe you just accidentally set Archivable to false in the part’s properties?

I checked that and it is true. It was never disabled. I also disabled any script like the original poster said and did all any other checks. It still happens.

Additional: I moved the place to a new game file, and it worked until I reopened studio. I also created an entirely new part moved it to the same CFrame and named it the same and it still disappeared. Even when I publish the game it happens.

It only started happening after Roblox went down.