Animation directions are not working fine when animation is loaded

Hello, im making some animations for an fps view-model.
When i animate in the Roblox Animation Editor, the animation is as i wanted to be, and directions & easing styles work fine. But when i load it in an Humanoid, directions are not working fine, seems that all the keyframes are in the In direction, and not Out as i wanted.
Here’s how it should work:
https://gyazo.com/3032f34c802a7c1ebc3fb3716e64f8c2
Here’s how it works when i load it in:
https://gyazo.com/2ec75f050a0f403e788484c147c28e6b
I noted that this happens to all my animations, and i really need help.
I also tried to switch the directions to In and then Out for each keyframe, but it still doesn’t work.
Every advise is welcome. Thanks.

What is the script you are using to play the animation?

I have a folder that contains all the animations, then a script loops in them and after it loaded all the animations to the humanoid, it adds the tracks into a table.
Once it did this, i can just type:

tracksTable[animationIndex]:Play()

or

tracksTable[animationIndex]:Stop()

Oh, and also, the script im using is a module script, that is local for each player.

Hey, i think a found a solution to this problem!
As i thought, it is an Export problem of Roblox Animation Editor.
Now im using Moon Animator, https://www.roblox.com/library/4725618216/Moon-Animator and it works nice, directions and easing styles are ok.
Now im animationg other animations and im uploading them via Save to Roblox.
I think also that “Overwrite an another asset” button doesn’t really help the upload, so i always create a new asset.
Here’s how it works now: https://gyazo.com/1ee206bd18b507eaa0d1f28288d8006a

(In the GIF seems like the animation is low fps, but in game, it’s 60 fps so is nice.)

Thanks to all who helped me, and i hope that this solution will help other people. :+1: