Animation doesn't load

Hello!
I made a custom rig with a looped animation
it doesn’t seem to work when i run/play the game.

this is what it should look like:
https://gyazo.com/7c711c4901759da8e2d5522651556f7e
this is what it looks like in-game:
https://gyazo.com/9961cf2e8d6b47d76ff9c280c8f9e90a
rig:
https://gyazo.com/b351ba24fb5d3b0c783e5054bff9dd8b
script loading the animation:

local h = script.Parent:WaitForChild("Humanoid")
local a = h:LoadAnimation(script:FindFirstChildOfClass("Animation"))
a.Looped = true
a:Play()

2 Likes

Is it normal that there isn’t any bone in the rootPart ??

Try this

local Humanoid = script.Parent.Humanoid
local Animation = Humanoid:LoadAnimation(script.Animation)
Animation:Play()

Hi, thanks for replying. It doesn’t seem to work though.

Try to put the Parent of the Humanoid, Animation, and Script into the model instead of it being a parent to the RootPart that might fix it.

Still doesn’t work, it stays still

A player character’s humanoid has an instance called Animator. You can load the animations here instead

also Humanoid:LoadAnimation is deprecated


local animator = humanoid.Animator
local anim = animator:LoadAnimation(script:FindFirstChildOfClass("Animation"))
anim.Looped = true
anim:Play()

It still doesn’t work.
Is there any possiblity that the problem is actually the rig?
I used blender and i made individual armature for each part like this

hmm the video showed that the animation had worked on the animation preview, so the rig should be alright.

Maybe retry doing this again?

local animator = script.Parent.Parent.AnimationController.Animator
local anim = animator:LoadAnimation(script:FindFirstChildOfClass("Animation"))
anim.Looped = true
anim:Play()

it still doesn’t work
oof, is it normal that there isnt any bones inside the rootpart
also, sorry for late reply

1 Like

i tried to change the priority but it still doesnt work??

ok nevermind. I just learned that we never put the humanoid inside RootPart, we parent to the model itself

1 Like