Animation doesn't play after moving the HumanoidRootPart

What do you want to achieve?

I want to play a animation on a character after moving its HumanoidRootPart.

What is the issue?

The animation doesn’t play when I move the HumanoidRootPart aka PrimaryPart of a R6 character model.

janisanim1:Play()--animation not working
		print("end") -- no feedback

The person standing should’ve played a animation when the red guy says AHHHHH

The line that’s causing problems
JanisHum.Parent.PrimaryPart.CFrame = doctor.PrimaryPart.CFrame

What solutions have you tried so far?

I’ve looked in the Devforum for similar problems that others could’ve had, but I didn’t find any. I’ve tried not moving the character and the animations played, but that’s not what I need.


is you perhaps load ze animation?

After moving the character? Because I load all the animations when the cutscene starts with this small function

local function LoadAnimation(Humanoid : Humanoid, AnimationId)

	local Animator = Humanoid:FindFirstChildWhichIsA("Animator")
	local Animation ="Animation")
	Animation.AnimationId = AnimationId

	local Animate = Animator:LoadAnimation(Animation)

	return Animate

end -- load animations shortcut / returns animation track loaded on animator
1 Like

I’ve somehow made a workaround to this problem, instead of changing the cframe I just set it to the position I needed it in and put it in replicated storage, and afterwards made the script change its parent to workspace.
But I still want to know what is causing this problem

1 Like