Animation Doesn't works right hand doesn't move

the right Hand, right upper arm doesn’t moving.

even though it prints test1 and test2

remotes.ToolActivatedRemote.OnServerEvent:Connect(function(player)
	local amount =Rewards.strength(player,Stats.strength(player),true)

	remotes.TextChange:FireClient(player,amount) -- Sending updated data back to client
	print("AnimationTest1")
		local animationTrack= humanoid.Animator:LoadAnimation(TheFirstAnimation)
	animationTrack:Play()
	print("AnimationTest2")
	end)	

am I doing something wrong?
I tried the script with a different animation and it works (right arm still doesn’t moves but other parts do)

I am open to all ideas. 30 thing

Maybe try playing the animation on a local script? I made some animations play trough a local script and everyone sees the animation, I don’t know why btw. I’m a bit new to the forum.

1 Like

Does changing the right arm animation priority do anything???

1 Like

Yep! it worked Thank you. this kind of moments feel weird because well, I Tried to fix it for like Idk 4-5 hours? Readed so much posts and watched many videos. then, some guy teaches you how simple solution is. Thanks again.

But can you explain HOW? and WHY? this is worked

I barely know :joy: but the general idea is if you need it to overlap another animation (like the idle animation) you need to set its priority higher than the (idle)

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.