Animation doing odd IK

Hello everyone!

So currently my animation is doing some sort of weird IK physics without me wanting that implemented at all, is there a way I can turn this weird forced-feature off?


Basically I had the UpperTorso face the mouse for part of the system, and for some reason the arms automatically continue to try and keep their place with some sort of IK from what it seems.

The arms SHOULD follow with the torso to also face the mouse without me having to implement a whole other few lines to have it all face the mouse.

I never tried to have this implemented and I never programmed anything to do this, so it is probably a Roblox issue.

Any potential fixes are appreciated.

(Don’t mind my avatar’s huge forehead thanks)

Thank you!

Bumping this post up so more people can see and possibly help with this issue.

1 Like

Bumping post again since its been another 3 hours.

1 Like

Bumping this post for a third damn time…

1 Like

Seriously can someone actually respond with a reasonable answer to this post its been 4 days.


alright nevermind turns out retargeting was enabled without my knowledge

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.