Animation Editor - Break after deleting a rig


The built-in animation editor breaks/errors on rig setup. This occurs after deleting a rig before closing the window which is a very easy mistake to make.

Repro -
Create a dummy > Open animation editor > Create Rig > Create some keyframes.
Delete the dummy > Close the animation editor window.
Create a new dummy > Open animation editor > Create Rig.

Here is the repro in an empty baseplate place.
Using the latest build: 0.403.1.344866 (64 bit)

Doing this makes the animation editor unusable until Roblox Studio is restarted.



Hey, I was unable to reproduce the behaviour after following your steps. Could you provide some additional details? E.g. rigs affected, a repro file, a video, more detailed steps.

I tried using each R6 and R15 rig provided by the rig builder. There was an unrelated issue with R6 rigs, however it doesn’t sound like the issue you’re describing (it was a rig warning and the editor was still usable). What I tried: 1. opening the editor and creating a rig. 2. deleting the rig from workspace. 3. closing, re-opening the editor and selecting a different rig of the same type.

I am running version 0.403.1.344866 on a 64-bit machine.

If possible, please also attach the .rbxm animation editor, located: %localappdata%\Roblox\Versions\{VERISON}\BuiltInPlugins\AnimationEditor.rbxm.

For reference: AnimationEditor.rbxm (216.3 KB) .


Updated the OP with additional details.

1 Like

I’m able to reproduce it in all rig types now that the create keyframe step is specified. Cheers.


Thanks for bringing this to our attention and for providing clear, reproducible steps! I will look into the issue

1 Like