[Animation Editor] Configuring parts Moves entire body except from the part I want to move

I’m currently trying to animate an evil robot for my tycoon yet whenever I rig it I get the same problem where I will go into Animation Editor and it will move the entire body and the floor grid but the selected part and its children do not move?


Any help is greatly appreciated - thanks.


Going to bump this; did you find a fix or did anyone have suggestion? Currently having the same issue but with the mover, trying to move the selected piece up causes the grid to move down while the piece stays in place. Very weird behavior.

Additional info: I used blender to model it, I’ve tried both fbx import rigged, obj unrigged and then rigged manually in studio. The model in blender has had all transforms applied, is at origin, and seemingly imports into studio fine. Animation editor opens it fine too.

1 Like

Bumping this again. Exact same problem. I’m surprised more people haven’t encountered this. In an effort to be useful here is what I already tried with no luck. You won’t believe me:

  • Duplicated the model and delete-and-re-added the humanoid and anim-save object
  • Deleted the “offending” part only to have the floor-grid revolve around ANOTHER part…

So the only thing I can say conclusively so far is that when I removed all of my mesh parts from the model, it behaved normally again. So obviously there’s something about mesh parts that causes this…

1 Like

Not sure if this helps but my problem was anchoring.

I had to anchor my rootpart and unanchor everything else in the model and then it worked


mine does it even without mesh parts. Super annoying

1 Like