Animation Editor crashes when loading an relocated CurveAnimation

Animation Editor crashes when trying to load or import a CurveAnimation that has been relocated (moved to a different location than inside the animation editor at any point)

Reproduction Steps:

  1. Create new place
  2. Create a rig using the Rig Builder
  3. Create an animation and give it a keyframe (move one of the joints)
  4. Convert it to a Curve Animation using the button on the top left of the Animation Editor
  5. Save the animation
  6. Close the editor
  7. Move the CurveAnimation from AnimSaves to a different location (ReplicatedStorage for example)
  8. Move the CurveAnimation back into AnimSaves model
  9. Open the animation editor
  10. Load the animation (It will crash)

You can also try publishing the CurveAnimation object (after moving it) to the website and importing that into a rig.

Reproduction Files:
I’ve attached a place file that has reproduced up to step 8. If you open the animation editor on the rig and hit Load -> test, studio will crash.
curveeditorcrashtest.rbxl (84.9 KB)

Beta Features: This has been tested with both ALL beta features enabled and ALL beta features disabled
System Info: This is happening on Windows 11.

Expected behavior

The animation editor should not crash


There is currently no way for me to recover my animations that I created previously so I can’t edit them.

1 Like

Is this your issue?


I believe so but I’m not sure. Publishing is not a necessary step in my repro steps.

1 Like

Hi there! Thanks for your report, we’ll look into this immediately.

1 Like

Hi, I’ve taken a look at this issue and fixed it. It will be live soon. Thanks for your report.

1 Like

Update: We have been able to reproduce the issue and we have a fix. This fix allows us to load your animation as well, so be assured that your work won’t be lost. Unfortunately this will require a new release of Studio.

As a workaround, you can delete the NamedKeyframeEvent instance that you can find directly under AnimSaves/animation name/. This will delete all the named keyframes created in your animation (including the “End” keyframe created by default), but it will allow you to open your animation with the current version of Studio. If your experience requires named keyframes, you will have to add them back manually when the fix is live.



Is this fix live yet? I’ve tried to load a CurveAnimation recently and ran into the bug.

For anyone else running into this, if you don’t want to mess with deleting anything you can use a plugin that converts a curve animation to a keyframe sequence, then turn that back into a curve animation in the Animation Editor

1 Like

My studio is still crashing when I’m importing animation curves, please fix. :frowning:

1 Like

Hi there.

A few weeks ago we fixed a bug that prevented named keyframes from being exported for curve animations. Unfortunately, this caused the crash mentioned in this thread. We had a fix for that, which we enabled for a while, but it then revealed another bug further down the animation pipeline in the engine and we had to revert the fix.

We have decided to revert the original fix as well. This means that once again named keyframes won’t be exported for curve animations, until we solve the final bug.

You should reopen your animations in the ACE and publish them once again. This would remove the named keyframes causing the issues you are seeing.

Our apologies for the delay and the inconvenience. We appreciate your patience.


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.