Animation Editor has moved out of Beta again

Cool! Can’t wait until we have mesh deformation


Sweet! Excited for the future of animating. :slight_smile:


Nice! I was waiting this, now I can make more with this feature without in Beta release.


Automatic as long as you’re opening up the studio app fresh, it should prompt download.


What was in the beta that wasn’t in the default editor?


A list of improvements can be found here: Keyframes Animate Everything Around Me


I personally find it harder to use than the last version.

Whenever you try moving the limbs around on a dummy, they’re more stale and it’s harder to make poses for thumbnails. IK doesnt help either.

It’s sorta hard to describe my issue in further detail without video…

Basically, it’s exactly like trying to build something without using any building plugins for example.

I dont know if there’s a way to give my pose dummies that ragdollness flexibility again like in the last version, but if there is. I’d appreciate it if someone told me how to do so.


I’ve been using it for something between 20-30 hours since the Beta release. The new one is pretty good. Definitely took some getting used to but it’s better overall. I forgot to record any problems I found so I’ll post them whenever they come up again, but it was something along the lines of weird keyframe overlap/clipping bugs and max anim length not being accurate for anims <1s.

1 Like

Please, give us an option to toggle back to the old one, I personally find this difficult to use.

Indeed the interfaces and functions are more advanced, I saw multiple improvements and bug fixes. However I still prefer the previous which was less complicated. How do I even snap grid in this new animation editor? I can only rotate objects in 45 degrees. Moreover, in the previous editor, we can simply toggle local and world coordinate by pressing T. I also dislike where you can no longer copy keyframes between 2 different animations.

Please correct me if I misunderstand anything.


I’m really happy you fixed the nested parts that were not working before.

Amazing! Animation Editor is very useful for everyone (including me) by animating actions, movements, etc. :movie_camera:

I’m really appreciated that Animation Editor has been moved out of Beta, since I’ve checked with the beta version too. Thank you for the update! :happy3:

1 Like

I’d like to say that I am really in love with the new animation editor, and it’s so much easier to create fluid animations. A lot of things are in great places and it’s clear a lot of work and thought has gone into this - bravo :slight_smile:

I do have one nit-pick though - it is now impossible to move between local and relative position / rotation without use of a keybind. This also doesn’t work when the model rig is at any angle to the world position, which was not previously the case. Can we expect a resolution for this?


Can someone confirm this? After I export an animation to an existing animation (overlay it) and import it again, it will import the previous version instead of the re-exported animation, but when I try to play it in game, it shows the newest version. I have to relaunch Studio to fix that.

Plus, it seems that the animation FPS is not publishing? Whenever I publish an animation to 60 fps and I import it again, it shows that keys are not aligning, it it an expected behavior?


Yea, I personally would love an opinion to toggle on and off this new one, due to the massive amount of opinions on each side!

1 Like

Your snapping options have merged their workflow with studio, so you can just edit them under the MODEL tab and those changes will also take effect in the animation editor. Ctrl + L is the studio toggle for local/world space and is now also the toggle for the animation editor. We can consider adding back a second hotkey.

1 Like

If I’m understanding correctly then this sounds like a bug. I’ll look into it


We force the timeline length to be a min of 1s. Timeline length and animation length are not the same though. The animation length is determined by your last keyframe, you should notice a section of your timeline is slightly grayed out past your last keyframe.


Not sure if this is the issue you are having, but there was an issue with IK described here:

There is a fix for this on the way

1 Like

Thanks for the solution on that!

I had another question, why does this pop up everytime whenever I import an animation?

Even though I republish the animation after I click “Align all keys now” and republish the animation and import it again, this still pops up, and the animation FPS changes. It this an expected behavior?

Plus, is this also an expected behavior? Thanks :pray:


Sure, so it depends on where this imported animation came from. When you import an animation into the new editor, we run an algorithm to determine the best fit for a framerate to edit in. If the animation came from the old editor (where you were able to key everything in fractions of a second), it’s possible that a reasonable framerate could not be detected. So instead of messing with your animation, we give you the option to keep keys unaligned to frames, or to force all your keys to snap to frame boundaries. Ignoring the warning above will keep your old animation intact. But the second you start dragging keys around, they will snap to the closest frame number.

See post here for more about how it works: New: Set Custom Framerate in Animation Editor Beta

Now as for your overwriting export issue, I am able to reproduce this as well. Although I have yet to determine if it’s an animation editor issue or an issue with publishing itself. I will continue to investigate