Animation editor not letting me edit custom rigs

I’m trying to animate a custom rig using the animation editor. I’ve done it twice in the past using the exact same setup and hierarchy with no problems at all. The hierarchy of the model I am trying to edit looks like this:

plus a bunch of other parts that didn’t fit in the screenshot. The model itself looks like this, if it matters:

The model is properly rigged using Motor6ds, using the exact same process that I’ve used twice in the past. The hierarchy of this model is identical to other models I’ve animated without any problems. When I select the model after bringing up the animation editor and click Create, I get this error:

I’ve gotten this error in the past but it usually went away after restarting studio. I even re-rigged everything in the model twice and I still get the same error. A note: the PrimaryPart of the model is indeed set to HumanoidRootPart.

also i didnt know where else to post this so if this isnt the right category tell me and i will change it to wherever it needs to go thanks

Are any of the parts anchored?

1 Like

No. Funnily enough, when you commented I was in the process of trying to animate a different model and I got the same error, so I decided to check to make sure none of the parts were anchored. I unanchored all of the parts and it worked.

However, for the model of topic for this post, none of the parts are anchored and it still does not work.

I’ve now re-done the rigging 3 times, making sure to make everything exactly the same as the model I just animated that works. Why does the animation editor just not like this one specific model? Everything is the same as other models I’ve animated.

I recommend using other Animation editors than the original. Legacy Animation Editor or Moon Animation Suite should be ok.

I finally got it to work. I guess something was off with the welds. Not the motor6ds, the welds that held every part together. Odd, because I used the same method of welding as every other model I’ve animated. Out of frustration I deleted all welds in the root part except for the motor6ds and it worked, then I made the animation and re-welded everything and it works fine.