Animation Editor not working at all

You can write your topic however you want, but you need to answer these questions:

  1. What do you want to achieve? Keep it simple and clear!

sorry if this is in the wrong place, but this is where I decided was best to post it since I cannot post on the platform bugs section

I am attempting to animate a simple Roblox rig, but when I click on the rig nothing happens. The animator stays how it is before anything is clicked and I get the error below. (follow by a screenshot of how the animator looks when a rig is selected)

Screen Shot 2021-01-28 at 6.18.42 PM

I’ve looked seemingly everywhere for someone with this same issue, but there are no post or nearly related issues to mine and I hope there is a fix for it because I am attempting to animate a lot soon.

Thanks to anyone who helps.

Bump, I searched this up again as it hindered me once more, still no solution, and it’s only one specific place my group owns

Very sorry to bump this thread, but I’m experiencing this exact same issue.

Very peculiar and persistent error. may have to migrate my studio project
Studio Version: Version 0.502.0.5020362 (Latest at time of posting)

EDIT: I’ve got a working solution. In the Workspace Explorer there was a folder named ‘ROBLOX_R15_IK_CONSTRAINTS’, deleting this folder completely solved the issue.

The folder contained the hinges/joints/constaints that typically connect r20 models together.
Theres something about that folder that the plugin did not like, I noticed that if I create another IK it will create that same folder again, but this time without issue. I think this error still needs to be addressed in the Animation Editor code, to prevent this sort of thing from happening.

1 Like

For me this also seemed to work! Defiantly could not have noticed it in my game as there’s tons of folders but I agree that this should be fixed by Roblox especially since it could be tied to an underlying issue.