Animation in custom rig not working

im using an animation made in blender imported to roblox with priority set to action its only meant to play once and not loop, all the parts in the rig are unanchored except for the HumanoidRootPart

In play testing I ran a script via server and within testing it, I inserted an animation instance in the robot3 instance, then inserted an animator instance in the animation controller already inside the robot3, put my animation ID in it, then did this:


I tried unanchoring the root part but no change was made and animation wouldn’t play when I ran the code.

If you need any additional data please ask me and I’ll attempt to provide it
Looking for answers everywhere dw and If I find it I’ll reply to this thread
No errors, in the output it was gray text so it ran fine, the robot just didnt do the animation. (u can kinda see a snippet in the output where there’s gray text to show I ran it in the command bar)

In animation editor, it looked just fine playing the animation like its supposed to, just trying to implement it via code is not functioning


HEYY!! figured it out! started working on it again today and its something weird that I don’t get, so if anyone knows why it works because of this, please reply. So, instead of loading the animation and playing it in the animation controller I do it on humanoid, but it didn’t work at first. it wasn’t until I created a new animation instance and parented it to the humanoid, and IT ONLY WORKED when I deleted the old animations controller instance, what’s weird is if I try playing it, as soon as I delete the animation controller it plays, no matter how long ago I ran that code to play the animation, it doesn’t do it, and then when I delete the AnimationController it does play the animation.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.