Animation in-game does not match editor

I’m making a sword system for my game, but the idle animation I’ve created does not look the same in-game when compared to the animation editor

In-game:
image
image

Animation editor:
image
image

I’ve checked everywhere online, but I haven’t been able to find a fix for this issue. If anyone has a solution, please let me know :slight_smile:

1 Like

Try setting animation priority to Action

Didn’t change anything, it still looks the same
image

Best I can say is that the tool isn’t named correctly thus causing the tool to not animate correctly this is not likely, but, that’s all I can think of for why it won’t work

The tool has one mesh in it called “Handle”, it’s named the same under the animation rig, so I don’t think it’s causing any issues.

Only other thing I can think of is that I am using a motor6D in the rig (to connect the sword to the arm), but I already have a script that sets one up when you equip the tool.

If you have one part named “Handle”, Roblox will automatically set it to the default grip position, so you won’t be able animate it.

My workaround is renaming it to something like “Grab”, and making a script that when equipped, welds the grab part yo the player’s hand.

(Make sure the tool has RequiresHandle turned off)

I renamed the “Handle” to “SwordHandle” but it looks like this now. I made sure that requiresHandle is off too
image

You have to use a Motor6D if you wanna make the sword animatable. Basically you’d be making it part of the rig. Use a rigging tool to rig it onto a dummy’s hand, make the animation, and then through code you’ll have to clone the sword and set the motor’s Part1 to the character’s hand.
This is a very bare bone explanation but it’s the only way to animate tools correctly.

I have a motor6D set up already, and it works fine with other animations for this sword. This animation specifically is causing issues

Animation rig:
image

Server script (in player.characterAdded)

Player:
image

Motor6D settings (in game):
image

Unsure then. Make sure the name of the Motor6D you use in Studio is the same as the one when play-testing.
So if the Motor6D you use when creating the animation is called “Motor6D” make sure it’s called the same in game.

Still not working. Guess I’ll have to leave it as is for now

Thanks for tyring to help though :slight_smile:

Solved!

It turns out that I had moved the sword in the animation rig OUTSIDE of the animation, so the actual default position of the sword was different to what the rig showed.

I reset the position and redid the animations, and everything works now!

Thank you to everyone who tried helping me out :smiley:

2 Likes

Wait what do you mean, How did you reset the position?

When I created the motor6D in the animation rig and attached it to the sword, it automatically moved the sword to the arm.

I then moved the sword to the right position BEFORE I started animating

To fix it, I redid the motor6D, but instead of moving the sword outside of the animation, I left it as is and did all of my changes in the animations

hopefully that makes a bit more sense

Wait i don’t even have motor6d I just have the sword as a tool inside the character and I animate it like that. Do you perhaps know what I could do to fix the issue with that? Also when i delete the katana on the client the idle animation goes to the correct place

As @DEVLocalPlayer said, you have to use a motor6D to animate the sword correctly. Roblox automatically creates a motor6D called ToolGrip for any tools that have a handle part. Since my sword was not named handle, I had to manually set up a motor6D via script whenever the tool was equipped

Hey i just added a motor 6d named ToolGrip and I didn’t move the sword or anything only in the animation but the same thing still happends. Like exactly the same thing where for some reason the sword is above and not like i want it.

This is the tutorial I followed: https://www.youtube.com/watch?v=mkg5WoOiwrQ&list=LL&index=1&t=6s

Not exactly sure what might be wrong, but here’s what got mine to work.

  1. I renamed the handle of the sword to something other than “Handle” (ex. “Grip”)

  2. When you set up the motor6D for the animation rig, don’t move the sword outside of any animations. ALL movements and edits dhould be a part of the animations

  3. Set up a ServerScript that will create a new motor6D to attach the tool when a player quips it. Make sure it is exactly the same (same name, same Part0 and Part1, same parent, etc)

I’ve attached a photo of the ServerScript in a previous reply if you want to use the same one

1 Like

Hey yeah i figured it out i forgot to rename the handle to something else. Thanks for your help though!!

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.