Animation in-game doesn't look like it does in the Animation Editor

I’m having an issue with an animation of a character that should look like this:


the gray part you see is actually welded to the character using Motor6D(C0 is the humanoid root part), and im animating it like any other body part.
(I intend to use that part as the camera for a cutscene but i don’t think that’s relevant for now)

Now the issue is this is how it looks like when the animation is played in-game using a script:


There’s a noticeable gap between the camera and the character compared to the animation in the Editor, i thought it could be either because the animation of the “Camera part” would start earlier than the rest of the body parts, which actually doesnt make sense, OR it’s speeding up on its own, which also doesnt make sense :skull:

EDIT:
On second glance, i noticed the issue might be with the character itself, it’s feet seem to be sliding while it’s walking, which means its “walking” slower? but this is an animation how is it “walking” slower???
HRP is anchored and body parts can’t collide, so its not a problem of collision

What i want is for it to look exactly like the animation in the editor.

As for the solutions i have tried, well theres a bunch of them:

  • Changed animation priority (tried Core, action, and movement, in despair)
  • Enabled the Massless property
  • Made a similar part attached to the HRP (using Motor6D) and welded the Camera part to it (changed C0)
  • Separated the character’s animation and the part’s animation
  • while separated, i tried slowing down the part’s animation with code
  • Reduced the amount of keyframes

I might have tried something else but that’s currently all i could think of.
If the amount of keyframes/length of the animation could be an issue, here’s a screenshot of the animation tool. If i were to zoom in, you’d see that at every single timestamp there’s a keyframe.

Thank you in advance :pray:

1 Like

How is no one else having problems with this? I am trying to make a character rolling animation, in the animation editor the character is as it should be- above the floor from beginning to the end. But when playing the actual animation on a character, it makes the character WAY into the ground, meanwhile the HumanoidRootPart is at the same exact point.

This is extremely infuriating, and It’s enough to completely disrupt my workflow until I find out someone is working on a fix. How can I have a steady flow of making animations if I don’t know 100% that the end result will be the exact same?

I am actually about to make a post about this with video evidence, and with no surprise, will probably receive 0 response and 0 insight on how to fix or what causes it.

So much for making my first 2D game.

1 Like

Proved myself completely correct. What a mess.

Hello there, I’ve found a not-so-reliable work around so I chose not to post anything here in the hopes of getting a response that fixes the actual problem

I actually ended up adding a linear force to the root part and tweaked it to look like the character is actually walking like it should be. and since the character stops at some point, i had to time that as well in a script.

But I’m only lucky to be able to use this because my character is walking in a straight line, I wouldn’t be able to use a linear force with a much more complicated animation as that’ll be incredibly inefficient :skull:

In brief words, this solution is specific to this case only so it technically doesn’t count as a solution.
Roblox studio is very buggy so you’ll see a lot of these issues along the way, but don’t give up on your game just yet :pray:

2 Likes

Oh ok, that’s good that you found a workaround. It sucks that now some animations aren’t turning out the way they are supposed to while it is being animated, as it has been working fine for so many years. It’s something that needs to be fixed, but they notified me that they submitted a ticket thankfully. Not sure how long this will be :roll_eyes: