Animation in game is different from in the editor

I made an animation for the rig with bones and published it. The in-game animation looks very different from the one in animation editor.
This is how the animation in the editor looks like - it’s very smooth and you can see the spikes slowly reaching the end goal.

and this is how the published animation looks like played in game, I made no changes to it.
It’s no more smooth and rather abrupt…

I have also tried playing the animation without publishing it (KeyframeSequenceProvider), in case that was a problem, but it seems the result is the same as the published animation. And I have no idea what causes this…

1 Like

Hello, I hope you are well. If you want to see my publication: I had the same error a while ago, here is the solution.

go there and if it works for you put this post as a solution thanks

I’ve seen your post and we’ve got different problems unfortunately. I tried setting the priority to Action4 anyway, didn’t work.

sorry… I’m going to watch a tutorial on YouTube to see if I can help you. As I am from the Latin American community there is more variety

Found out it’s a glitch with the Cubic EasingStyle that’s been for a while!
If you are having the same problem as me, switch EasingDirection: In → Out, if you want it to have a slow start and vice versa. Hope they fix it ASAP!

2 Likes

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.