Animation Is playing with half weights?

The animation I created for my viewmodel is not playing correctly.

What the animation Should look like:

I find this strange because I’ve worked with basically the exact same system before and it worked fine

local ViewModel = Primary.ViewModel.Value:Clone()
local Animator = ViewModel.Animation.Animator

local VM_Idle = Animator:LoadAnimation(ViewModel.Animations.Idle)
VM_Idle.Looped = true
--Yes this is the entirety of any animation related code I have

Have you tried manually editing the animation’s priority? Ex:

VM_Idle.Priority = Enum.AnimationPriority.Action4

This shouldn’t be an Issue, as the animation priority is Action and no other animations are playing.

Also, changing animation priority through code was broken last time I checked.

What about printing all the animation tracks?


I scaled down the Viewmodel for various reasons, im going to remake the joint’s and see if that fixes it

When printing the animation tracks, the only one that says it’s playing is the one I made

I also tried increasing the animation weight and priority, which did not work.

Then it’s most probably an animation problem rather than a scripting problem.

I got it to work

It was an issue with the model scale, just not the one i thought it was.
I fixed it by regrouping the model so the scale was set to 1.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.