Animation is working correctly when in animation editor, but not in game?

Hello! This is my first post, so if I do something wrong or bad I’m sorry.

So, to the point - I am trying to make an animation play in game of a character entering the room, looking around, then exiting the room. This is what it’s supposed to look like/ what it looks like in the animation editor.

But this is what i looks like in game:

I tried to look around if anyone else experienced this problem but I couldn’t find much information on how to solve this.

More details:

  • I animated this in Blender and exported/imported the rig and animation using the Blender rig exporter/animation importer.

  • I have never experienced this problem with other similar animations I’ve made.

  • I used the IK feature in Blender to make it easier to work on the walking part. Maybe that has something to do with the problem?

Feel free to ask me more questions in the comments. Thank you in advance!

2 Likes

Try moving the character’s model forward?

If I move the character model forward, the door moves with it (I rigged the door to the humanoid root part)

Maybe this might break the animation even more, but try disconnecting the door and character, move the character forward, and join the door and character back together.

1 Like

I don’t know how that will fix the animation, but I will try.

Nope, didn’t work. Just plays the animation in one place like last time.

I feel like this has something to do with the lower torso because when you see the in game animation, you notice that the lower torso rotates, but doesn’t move…

This could be “HumanoidRootPart” is anchored or one of the part is anchored on body itself

1 Like

I un anchored it and tried earlier, but the same thing happens. Doesn’t move.

Also if I unanchored it everything just has a seizure (lol)

Is your humanoidRootPart anchored? it could be that the model is sliding backwards due to it being unanchored.

1 Like

I’ve tried it in both anchored and unanchored ways but the animation stays the same.

Hello everyone, this is just an update post to where I am now. I have learned that if the animation walks too far out of the grid in the animation editor, it will not move. I will probably make a script to make the character move inside and outside the house. Thanks to everyone that tried to help!

1 Like

Turns out I didn’t have to do any of that! I resized the HumanoidRootPart to be bigger than both the door and the character and positioned it right between them. The animation works perfectly now. Thanks everyone!

1 Like

ik it’s been a while
but that stuff is creepy ;-;

1 Like