Animation isn't playing when a humanoid model is welded to a player

  1. What do you want to achieve? I want to figure out how to fix the following issues

  2. What is the issue?
    1 - I’ve welded a Humanoid model to a player with a Motor6D and I want to play an animation on it, but the animation doesn’t play
    The humanoid model welded behind the player with a motor6D, animation doesn’t play.

2- after welding the model to the player, the player is now unable to jump, they get forced into the ground before coming back out ( )

3- More of a question, but does having a humanoid automatically make an animator, It doesn’t in my case

  1. What solutions have you tried so far? I’ve tried looking at the devhub for help but i don’t understand why the animation isn’t playing when I met the criteria, and it was playing fine on the player’s humanoid but not the models. the mode is in fact rigged and it does have it’s own humanoid

Instead of trying to wait for the model’s animator in the humanoid, i tried using an AnimationController instead but that also didn’t work

there are not any welds that are locking the parts in place so welds aren’t the issue

– the script to weld the humanoid model to the player AND to play the animation on the humanoid model. It’s in StarterCharacterScripts

PS = game:GetService("Players")
if script.Parent:FindFirstChild("Humanoid") then
Char = script.Parent
Plr = game.Players:GetPlayerFromCharacter(Char)
Stando = game.ReplicatedStorage["Stand Test"]:Clone()
Stando.Parent = Char
SW ="Motor6D")
SW.Parent = Char:FindFirstChild("Torso")
SW.Part0 = Char:FindFirstChild("HumanoidRootPart")
SW.Part1 = Stando:FindFirstChild("HumanoidRootPart")
SW.C1 =,-1.1,-1.8)
SAnimator = Stando.Humanoid:WaitForChild("Animator")
print("Animator Found")
IAnim ="Animation")
IAnim.Parent = Stando
IAnim.AnimationId = "rbxassetid://7345385646"
Idle = SAnimator:LoadAnimation(IAnim)

(My first thread so sorry if it looks choppy)

Did you un-anchor the model, Because that might be a prime issue. - If it’s anchored it won’t work.

Yeah, all the parts of the model are un-anchored

Are you trying to animate a custom character?

Yea, It’s the model behind the player i put in the image

It’s a rigged humanoid model but the humanoid in the model never gets an animator, and using an AnimationController also doesn’t play the animation.

Send a screen shot of the rig you want to animate.

This is it

Why not use just the roblox default rig?

Do you mean the rigs you can get from roblox’s rig builder? i got the model from MoonLite’s rig builder

Yes, use roblox’s rig builder.

Okay, i’ll come back later to share results

Alright, good luck man! Make sure to use the R6.

Okay, so i used the default rig and un-anchored everything in the model to be sure but now the player can’t move
Every time i spawn i fall into the floor unable to move, and anchoring and un-anchoring the model’s parts makes me able to walk for a second or two before falling into the ground again

Update: I changed the welds from HumanoidRootPart to their Torsos. i can move again but animation still doesn’t play.

Update: I can only walk for a While now before falling into the ground and being able to walk again soon after works fine again, weird. but the animation still isn’t playing at all and i still can’t jump