Animation: Not all R15/rthro rigs transfer animations properly

I loaded an rthro bundle into the game using a wear bundle plugin (which works off of BuildRigFromAttachments (or perhaps ReplaceBodyPartR15) and bundle API so I would assume the joints and etc should be correct) in order to make animations for a project, however it keeps giving me these terrible rotations on my character:

what I expected to get was:

This does, however, seem to work with a copy of the original character as a StarterCharacter

The point of this project is to work with all R15 and rthro rigs so this bug is annoyingly aggravating.
Afaik this happened when I was animating using IK but it should most likely happen in FK animations also (i disabled IK before exporting). I tried uploading the animation again multiple times (and there are no conflicting animations) and I also tried remaking it to no avail. I played the animation using the Play method from the API to test in the first and last recordings.
1 Like

Thanks for bringing this to our attention. Would you be able to provide me with a place file that has these models and broken animation in it so that I can investigate the cause?

1 Like

The plugin
I created a new r15 rig and then wore the gatito bundle.
I used the typical play method for the animation after loading it to my own r15 character in the game. I am using the bear bundle

1 Like