Animation not playing after I clone a viewport frame

Hello! I’m trying to make a character select option based off of Sonic Advanced for fun. I ran into a problem while creating it though. Im using viewport frames for the characters and I have a animation for said characters. It works normally, but if i clone the viewport frame, it doesnt work for some reason. Any idea why its not working? As you can see, behind the dummy without the animation you can somewhat make out a animated dummy.

also note, I load the animations using a script in the dummy itself and theres a animation in the dummy.
undefined (NaN [en.number.human.storage_units.units.byte count=undefined])

local hum = script.Parent.Humanoid
local animate = hum.Animator:LoadAnimation(script.Parent.Animation)

LocalScript (FOR THE CLONING):

	local currentt = gui.ViewportFrame:Clone()
	local nextt = gui.ViewportFrame2:Clone()
	local prevt = gui.ViewportFrame3:Clone()

	currentt.Visible = true
	nextt.Visible = true
	prevt.Visible = true

	currentt.Parent = gui
	nextt.Parent = gui
	prevt.Parent = gui
1 Like

Boosting this, still need help

btw this is how my dummy rig is formated. The image didnt load for some reason

1 Like

Is there any feedback that you receive when trying to play the animation under the viewport, such as an error?

1 Like

nope, no error at all.


Have you tried changing the model name ? (WorldModel → WorldModel2 same with rig)

1 Like

Tried this, doesnt work. Thanks for trying to help though

1 Like