Animation not refreshing inside ViewportFrame

Hi, everyone!

  1. What do I want to achieve?
    I want to clone the player’s character in a ViewportFrame and I want to add an idle animation to it.
  2. What is the issue?
    Adding an animation into a character basically works in the Workspace, for instance. However, in my ViewportFrame, I can see it works, but the animation only refreshes when I set the ViewportFrame visibility to false, and then to true. If I don’t do it, the animation won’t refresh, and I’m far from thinking this is the only way to achieve what I want.
    I precise the cloned character is the children of a WorldModel, whose parent is the ViewportFrame.


To be able to see my character correctly, I’ve added a Camera inside the ViewportFrame, which is set as the ViewportFrame’s CurrentCamera property.

Here is a video of the problem:

  1. What solutions have I tried so far?
    I’ve found many things on the web but I’m not sure those are the most efficient methods I can use in my game.
    One of them consists in deleting and cloning again the character each frame using RenderStepped, but this seems to be awful to manage. Doesn’t it exist a better way to achieve my goal?

Anyways, I’m sorry if what I’ve done is wrong, I don’t often use Viewports and I’ve never tried to animate any item cloned into. Thanks a lot for your help, I’ll be really grateful!

1 Like

I set it up with an idle animation and it worked fine there was just no running and walking animation

1 Like

Is it a part of a Canvas?

Yes, it’s parented to a CanvasGroup as the following image shows:


I’ve just found out the CanvasGroup is the problem!
I put my ViewportFrame outside of it and it works perfectly from now.

Thanks you @SomeFedoraGuy !

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.