Animation not working on custom rig

I am having a issue where the animation runs fine in the animation editor but if i run the animation in game via a script it just isnt working. As mentioned in the titel this is a custom rig that i rigged in blender and imported via the import character plugin. Below you can find media about the problem.
Thx if you can help me.

This is a video showing my problem in more detail:

This is the model hirarchy:
Screenshot 2022-09-02 214030

Here is the code i use in the video:

local model = script.Parent

local animation ="Animation")
animation.AnimationId = model.AnimationPack.Walk.AnimationId

local animationtrack = model.AnimationController:LoadAnimation(model.AnimationPack.Walk)
animationtrack.Looped = true

while true do
1 Like

When I used custom rigs they only worked when I renamed the model to “Part” or “part” I don’t remember which one, try both.

I have figured out that if i rename the RootPart to HumanoidRootPart it works perfectly fine. I just moved the origin in blender to center of mass so the RootPart end Bodypart merge so now it works perfectly fine.

1 Like