Animation of non-human characters issue


#1

So I am trying to animate an animal of sorts, not the default R6, R15 character types. I have created a model with the parts inside, connected everything with Motor6Ds using the character creation plugin and the joints look like this:

The explorer looks like this:
image

When I try and animate using the default animation editor, I can’t click on the animal because it has no humanoid. I add one and I can enter the editor. As it opens, I get this message:

image

Now onto the actual issue. When I try and move a part such as the head, it moves and then snaps back to the original position.

This means that I can’t animate. Any suggestions on a fix or am I missing something?


#2

Try changing the humanoid to R6. There is a setting under its propertes.


#3

Try turning off Inverse Kinematics - that’s the issue here I believe.

I haven’t had a problem relating to it just being R15 though, even if a character I’m working on doesn’t have 15 joints.

You may also want to consider having an animation controller for the actual animations.


#4

How do I turn that off?

Also @qqtt991 the humanoid was already R6


#5

Was the ‘R6 or R15’ mandatory animating option always there? I used to do custom rigs very frequently, and never had any problems creating rigs with more or less joints than R6 and R15.


#6

I don’t think that there is an option to change animation type. I think it works it out for you. I’m met with this error every time I try and animate something that isn’t the dummy from the rig builder


#7

I tried to open the animation editor with one of my old rigs I successfully animated, and got this same result.

Make sure your HumanoidRootPart is anchored and nothing else. I believe thats causing the joints returning to their original position. Other than that, the editor works perfectly fine besides the error.


#8

I recommend trying out https://www.roblox.com/library/745786060/Moon-Animation-Suite if you haven’t already. In the short time that I have used it I have found it to be far more forgiving than the default animator. Sometimes accidentally pressing hotkeys or closing out the animating window in the default one have screwed up my rig permanently, which is the absolute worst.


#9

Okay so I installed the animation editor and already like it far more.
When I animate my animal, only one join appears… Is this because of how i have set up the character? Could you help? (I am completely new to character creation and non character animation as you can probably tell)


#10

@RedDuck765 The warning prompt is just informing you that your model is not setup the way that is needed if you intended to use IK in the animation editor. Also, I having an AnimationController on the model will suffice to being able to select it if it doesn’t make sense to have a Humanoid on there. The bug with the parts snapping back after moving is unrelated to that, but I would love to look into it and address it. Would you be able to provide me with the model you are using so I can see what’s going on?

Thanks!