Animation only works in studio

I’ve made an animation for a custom rig. It work’s fine in studio, but nothing happens in game.
A few things that could help:

  • There are no errors or warnings
  • The custom rig has no Humanoid and is controlled with an AnimationController.
  • The game is owned by a group
  • The animation is owned by the same group

I can’t figure out why its not loading the animation properly. Is there something I’m forgetting?

1 Like

Did you try Googling your problem?

Yes, couldn’t find anyone with both a custom rig and a group ownd game

When you published your animation, did you select the group and not “me”? (Simple question to be sure)

Can confirm, the animation is owned by the same group as the game

You tried to add a print just before the animation to see if in game it goes there? Because as you are probably aware, sometimes things works on studio but not in game

No idea why, but putting a print before the :Play fixed it.
Roblox can behave very odd sometimes. Thanks for the help!

1 Like