Animation Play Load

I’ve been trying to do this for hours.
Here’s what I’m trying to do.
I’ve welded a tail to my character via the torso using SetCframePrimaryPart
I have the tail animated but I don’t know how to get the animation to play.
There’s no activation it is not like a activated tail, the tail is ALWAYS meant to be there which it is.

I’ve tried putting local/server scripts inside, here’s a picture of my explorer.

Please help me.

Did you create an animation? If you did leave the Id below @abys1fyzoneslackicys and do you want them to press a button to play the animation or automatic? I GTG rn so leave the ID below Ill get back to you around 12 PM EST.

Automatic animation

1 Like

here is the script tell me if it works!

local DemonTail = script.Parent
local Animation = DemonTail.Animation
while 1 == 1 do

local Anim ='Animation')
local Character = DemonTail
local AnimationTrack = Character.Humanoid:LoadAnimation(Animation)
Anim.AnimationId = '7349291811'

Also add a animation inside your tool, then click the animation, then click the animation value then put the animation ID in and your done. It might not work if it doesn’t Ill take a second look.

1 Like

You really shouldn’t use Humanoid:LoadAnimation() anymore. It got deprecated.

Here’s the post, you should follow.

And use task.wait(amount) instead of wait(amount). It’s an improved version.

Here’s the link to the post.

1 Like

@AridFights1 then what is a substitute for this?

Use an animator instead like this Humanoid:WaitForChild("Animator"):LoadAnimation(yourAnimation)

1 Like

can you pls be more specific? There is no script and why do you weld by using SetPrimaryPartCFrame?? You tried to play the animation but it didn’t work, right?