Animation playing incorrectly when played by an NPC

I have created an animation for an enemy in my game that involves the torso rotating. It plays fine in the editor, but once the HumanoidRootPart is unanchored and it’s played in the NPC the torso does not move and the HumanoidRootPart rotates instead.

Animation in editor:
Animation played by NPC:
(HumanoidRootPart is highlighted)

Things I’ve already tried:

  • Increasing the size of the HumanoidRootPart
  • Making parts other than the Head and HumanoidRootPart massless
  • Decreasing the density of other parts and increasing the density of the HumanoidRootPart

Any ideas on what the issue might be?

I’m having a similar problem.
This is what I want:

This is what I get:

I’ve found that if I set massless to false on the HumanoidRootPart, it fixes the animation bug.
However, this comes with another (more annoying) bug.
It’s like there’s an invisible platform under your character.

I’ve tried messing around with the HumanoidRootPart’s position and size.
I’ve also messed around with the Humanoid’s HipHeight.

Nothing seems to work how I want it

I’ve found that I can fix the rotation issue by animating in the opposite rotation of what I want.

This is not optimal but I guess it works.
I’m curious if anyone else has had a better solution to a similar issue.
Is this worthy to be classified as a bug or are we just doing something wrong?

Ok, this is getting ridiculous.
This is how it looks like in the animator:
This is what it looks like in game:
It seems to be mixing up the MainTorso with the HumanoidRootPart
Why is this happening?

Ok I seem to have finally fixed the bug.
I set both the MainTorso and HumanoidRootPart to have their Massless property set to true.
Then I made the HumanoidRootPart bigger.
This seems to have been the solution for me.

try changing animation priority, im not sure if it works but its worth a try.