Animation with a Motor6D'd Tool not working as intended

So, long story short, I wanted to make a simple swing animation for a tool and in the Preview it appears fine, however, when loaded through Humanoid and played within PlayTest it DOES NOT play as intended. Things I have tried:

  • Copy tool from the Humanoid I animated and change the Motor6D’s Part1 to the Handle of the Copied Tool, which worked, however this is supposed to be automated via a Script and this isn’t reliable.
  • Check if all properties on both Tools and Motor6Ds are the same, they are.
  • Reupload animation with a higher Priority
  • Try to copy my avatar from playtest and load up the animation on in the animation editor, which also played the preview fine, just as intended.
  • Upload the animation from the avatar mentioned above, it didn’t do anything.

Below I’m attaching Intended Animation, How it looks during Play Testing as well as the bit of the code that Motor6Ds the tool to the user’s Hand. It could be something obvious and I just overlooked it, no idea, but I’d appreciate some help, thanks in advance, I’ll check out any possible ways to fix this (if any get posted here) tomorrow as it’s 11PM already for me. If anything else would be needed I can drop it, but I think this information might be enough to help me narrow the problem down.


  1. Check the animation’s priority: Make sure that the priority of the swing animation is higher than any other animations that might be interfering with it. You mentioned that you already tried reuploading the animation with a higher priority, but make sure that the priority value is actually higher than any other animations that might be playing.
    Or maybe try 2.
  2. Check the tool’s constraints: Make sure that the Motor6D connecting the tool to the player’s hand is set up correctly. Double-check that the Part0 and Part1 properties are set to the correct parts, and make sure that the constraints are not overly restrictive.

I have double checked both already and they’re all pretty much fine, it’s the tool that doesn’t move for whatever reason, although straight up taking the tool that the Animation Dummy holds and manually swapping Part1 of the Motor6D to the handle of it when in Play Test actually makes the Animation play out fine, hence why I’m confused. :thinking:

Hmmmmm, I made a lil list that might help you, check it:
Check the tool’s properties: Double-check that the tool’s properties are set up correctly. Make sure that the tool is anchored, has CanCollide set to false, and that the handle is properly positioned.

Check for collisions: Make sure that the tool isn’t colliding with anything when it’s being swung. Even if CanCollide is set to false, the tool might still collide with other objects in the game.

Check the script that equips the tool: Make sure that the script that equips the tool is not interfering with the tool’s movement. For example, if the script is locking the tool’s position or rotation, it might prevent the tool from moving correctly.

Check the animation curve editor: If you’re using the Animation Editor to create the swing animation, make sure that the animation curve for the tool’s movement is set up correctly. If the curve is too steep or has any sudden jumps, it might cause the tool to move erratically.

Try a different tool: If none of the above steps work, try using a different tool to see if the problem is specific to the tool you’re using. If a different tool works correctly, there might be an issue with the tool itself.

Also, someone asked if I’am autistic, I’am autistic as shit.

Tried a different tool, still did not even budge.
Also noticed that if I run the animation on the Dummy itself while play testing the animation doesn’t play correctly either, works only if I manually Motor6D it to my avatar, it’s rather weird.

Checked everything else, also no luck with that.

Damn… I really do not know what to do now… Let me double check it, if I find something that might can help you I will tell you.

Have you tried destroying the ToolGrip Weld that automatically comes up when a tool is equipped? If there is a Weld and Motor6D welded to the tool then the animation won’t play as intended.

1 Like

Thank you!! I completely forgot about that part, it works perfectly now, can’t believe I overlooked that.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.