Animation wont work?

Today, I imported both character and animation from mixamo and it was a succesful.

However when i export it to roblox and try testing. The animation doesnt play :(. Tried some debugging and it says that the animation is “playing” by using the code

	while wait() do
		print(running.IsPlaying) --always returning true.

I have no idea on how to fix it. So I tried looking both in youtube and devforum but i still cannot find the solution to this problem.
Please help!


Can you show script where you run animation?Also you try to use it on starter character?

1 Like

Sorry for late reply!

Yes, it is located in one of the dummy i copied from the startercharacter.

I did some work around with the script so it now end up like this:

local animation = script.Parent.Humanoid:LoadAnimation(script.Parent.Animation)
animation.Looped = true
animation.Priority = Enum.AnimationPriority.Action3
animation.Looped = true

Yes i used it into starter character. Upload animations to roblox and then put it into the default animate script for the animator!
Still it doesnt work :frowning:


inside the animation editor. There seems to be mo keyframe? but the animation is running. Might that be the case?

I have found a solution to this problem!

It seems that I have press t he Import 3D file in which is very wrong.
You need to use this to fix located inside the plugins tab to fix it!
Also the Model must have a part called HumanoidRootPart inside!

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.