Animations in group games not working

I tested my animation script in a group game, it didn’t seem to work. I went to an empty baseplate and tested it there, it worked. I then went to another group game and realized it doesn’t work there. I started to feel a connection that the animation does not work in group games. Any solutions?

Here is the script:
Screen Shot 2020-09-05 at 2.56.41 PM

In Workspace:
Screen Shot 2020-09-05 at 2.59.56 PM

Emote Properties:
Screen Shot 2020-09-05 at 3.00.33 PM

I tested it in-game

1 Like

You can play any animation you want anywhere as long as its not paid animation.

You should try :

  • Set the animation priority to action. To do so, enter the animation plugin , import the animation and set its priority to Action.
  • Make sure the animation is on looped
  • Try to open 2 roblox studios with a game that works and a game that dances doesnt work and compare the scripts, properties, everything. Maybe you disabled something and forgot about it?
1 Like

I have tried and checked all of these. The problem is still not fixed.

Check the output of any errors or make sure the animation is ending as you wish. Other than that i dont know how to help. U can also check some youtubers

1 Like

Make sure that your animation is owned by the group, not by yourself - otherwise, it won’t load it in.


Just as @Doqee said make sure your animation is owned by the group.

1 Like