Animations on pseudo characters not working

Does anyone have a fix for this? It seems that my local script refuses to play animations on Humanoids dropped into the workspace. Filtering is enabled.

-- Models pathway: workspace.Cinematic.Models
local DummyModel = Models:WaitForChild("colbert2677Dummy")
local DummyHumanoid = DummyModel:WaitForChild("Humanoid")
local DummyPoseAnim = DummyModel:WaitForChild("PoseAnim")
local PoseAnimTrack = DummyHumanoid:LoadAnimation(DummyPoseAnim)


  • Client clones “Cinematic” folder to workspace
  • Client accesses Models and goes to “colbert2677Dummy”
  • Attempts to use Humanoid:LoadAnimation() and Track:Play()
  • Animation does not play

I have a feeling like it has to do with network ownership, though it really shouldn’t. Nothing worked when I placed it in CurrentCamera either.

I just tried the following in a local test server with FilteringEnabled on:

  • Clone model from ReplicatedStorage into Workspace locally
  • Load animation that is a child of the character (locally)
  • Play the AnimationTrack (locally)

It played for me.

Is it possible that your WaitForChilds are never succeeding? Does the character have a HumanoidRootPart? Are you sure you can load the animation (it’s yours or a group you’re in’s)?

Which environments do you experience this problem?

  • Play solo test mode?
  • Studio test server mode?
  • Online?

I don’t like myself. It’s one of those scripter “things” where I rework code and puzzle over it for so long to realize that the solution was right in front of my eyes the entire time.

The ownership of the animations was the problem.