Animator Troubles

I was working on animation sets until when I get to the legs, when I rotate or move one of the legs, the leg goes underneath the baseplate, or atleast it shows that it goes underneath. I refreshed my studio and tried it on a different baseplate but I end up getting the same result. Is this happening to anyone else? Please let me know. :disappointed:

Happens to me sometimes. Have no idea why it keep broken but It might be because I accidentally delete something. Get a fresh rig should fix it. If it dont, just reset studio and pray it will work.

Here a simple solution, start using Blender.

Here a better alternative, use moon animator.

1 Like

Lets me give you an even better solution, don’t listen to @astraIboy set yourself up for success by using a competent animation plugin like moon animator or the roblox animation editor!

I don’t use Blender or Moon Animator and I didn’t delete anything, I use the regular roblox animator that’s already in there.

1 Like

Oh it works now, thanks for trying to help guys.

1 Like

I was going to suggest maybe the pivot point had got knocked off track, but seems it already solved itself.

I use Roblox animator and it’s been fine for me, but, I’m only animating fairly simple stuff so there’s that.

I do the same thing, I animate walking, jumping, idle, and falling.