Annoying warning

sorry if this rong place to ask idk were else to add this…

so i made a gun model today and i have set the “CanTuch” proprety to false…
now it work all fine and it dont create a “TouchTransmitter” if you drop it but id like to know if there is a way to desable the warning it give you “Handle has CanTouch set to False. No TouchTransmitter will be created” each time i equipt my tool since it full the console for no reson…

1 Like

I don’t know how to disable the warn message but, you can check the warn options to false, to make warn messages not showing to your console.

It’s because you’re trying to do a Touched event using that part while it’s CanTouch property is off.
Either remove the touch event from your script if it doesn’t do anything or turn CanTouch back on.

1 Like

i did review my code and there is no “Touched” event in my gun the warning only show up once i equipt my gun and my gun seam to work normaly

It might be that there is another touched script somewhere else like a teleport and that triggers it.

its a world whit nothing else so i can work and test my gun system there is absolutely no tutch related to the part… i have for fun disable all script in my testing world and it still get the warning once i equipt the gun

You can check with the find / replace all feature. It could possibly be a model you inserted that is spreading a script.
You can write the word “Script” at the top of the explorer to see if there’s any loose scripts hidden somewhere in workspace.
Other than that it might be a bug somehow if literally all scripts are disabled.

well im go and say its like you said a bug i cant find no other script that try run tutched connection unles it somthing from the roblox side of things and since from what i see its a not so old feture
ty for trying to help im mark you a solved

1 Like