Another Roblox Studio problem: "Failed to Load Settings with ConnectFail"

I just started my day on Roblox studio and this popped up
Searched for others’ drafts, but nothing worked

I don’t even have regulars to report it to being a studio bug so I hope anyone can read this report it for me please

Having issues with this on Windows 10 Enterprise
And It seems like the area in southeast Asia (to be exact in Vietnam I live)
Not only that but the normal website becomes inaccessible.

Is it me experiencing it or is it everyone in this area being affected like me?

Affected since: Yesterday (29th March, 2024 - 30th March, 2024)

3 Likes

This also happened to me and unfortunately i have not found any solutions for this. However, i did research and yes, Roblox is currently crashing down on Asia servers connection. I am vietnamese myself and this happened to me BEFORE the weekend (around from 27th to 28th). Before this happened, my Studio suprisingly lag although my baseplate only has spawn point and 1 scripted NPC, usually bigger/larger Places won’t be that laggy but even my friend’s Window 11 PC couldn’t get in either. Restart Studio won’t help because it’s currently down and fixing (if possible) so results are from Roblox itself :neutral_face:

1 Like

Imagine roblox servers burning down lol

So now i think we have to use VPN to access, otherwise this will delay us a lot…

1 Like

yeah i have tried VPN and it actually works! (couldn’t reduce lags but i will find a way for that soon)

1 Like

can you share what VPN are you using? I’ve been waiting for a few days and they haven’t fixed the servers

I tried some free VPNs and they all don’t work

What problems are you encountering right now?
List to me all of the VPNs you used.

Maybe I can help on it

i use CloudFlare WARP it also includes an app for mobile devices

1 Like

There’s no problem it just doesn’t work doesn’t fix anything doesn’t change anything other than making my connection really laggy I was using Psiphon and ProtonVPN

Tbh this server issue is taking awfully long for Roblox to fix. They should have known this by now cause I can play the game but any gamepasses can’t be bought.

Have you tried Hotspot VPN? or any compilable with Roblox

Roblox fixing team is just non-existence now…
They said they are still “fixing on the issue” but it seems like no one from the Roblox staff reading this

This is really bad lol. I used VPN and it worked but the profile service data in my game is all messed up I think it’s because I’m on a different server now so it doesn’t recognize my data or something. I can work on my game but when I want to load my data and test the game i have to turn the VPN off.

Yeah this is a pretty big issue that’s been going on for more than a week, awful response time from the roblox team…

2 weeks since the moment Vietnam ISP disconnected from Roblox Servers :sob: but VPN still works well…