Archimedes 3 Creates Gaps Between Objects

I’m making a train game. I’m laying track. On straight sections of track, there are tiny gaps between the rails. Sometimes these gaps get bigger, sometimes not. The rail model is completely fine so nothing should be going on here, why is this happening?


This is likely due to your studio settings and the distance how much something moves

1 Like

Wdym “the distance how much something moves”
Also there’s no reason my studio settings should affect Archimedes

1 Like

Plugins can access your studio move increments, though that’s probably not the problem based on how “Sometimes these gaps get bigger, sometimes not”.

Could you send a screen shot? That might be helpful for narrowing it down.

1 Like

My move increment is disabled in this case anyway, but here is a screenshot. I don’t have any screenshots of when it’s REALLY bad (about a 0.3 stud gap) because I would move the track over the slightest bit but it still happens.

This is like the maximum I can let the gap be before the train begins to derail,

And here is a screenshot from my most recent track segment

In the second screenshot, each piece of track before this, the gap slowly gets smaller. Each next piece of track, it slowly gets bigger


You probably have studs offset into archimedes config. try disabling that or setting it to 0


No offset is set to 0.



Still not solved for anyone who would like to try and figure this out

Hey, what I believe on why the issue is occuring is based on how your original model was set up. Curvatures with a high variety of measurements in a complex model can cause issues. Personally, what I’ve done to overcome this is use a plugin called “Resize Allign” under GeomTools to fix the gaps easily, or use Blender and import the finalised version into ROBLOX.

1 Like

Issue is, the ties are a specific length apart, and some of these gaps make that extra length way too noticeable. But if this is the only way, then I guess I could find a way to make it look better

Why don’t you use editing software like blender others and have you squeeze in the rails

Because who uses a 3d modelling software to build a whole railroad circuit in this platform :sob:

There is no
rail roads in the studio

Yes there is, Roblox made a whole train set???
also no using blender is NOT happening because I need to keep it under 10k tris, which means I have to export it in tiny parts, just easier to build it in studio

This is still an issue if anyone would like to help

Did you try the "Auto-Resize option?

Without auto resize

With auto resize

I found it to work best with “Fix neighbors” off.

That only causes more issues due to the fact that my track is rails and ties, and I would have to assume the pivot point is at the end of the ties. Autoresize for some reason puts like a massive space between tracks sooooo

This is still an issue and has been hindering development for over a month now


I extremely recommend contacting the developer(s) of the plugin to see if it is an bug, or advice on how to workaround this issue. I have seen that this has been affecting you for over a month, and this would be the best course of action for you.

How should I contact the developers? Discord?