Archiving & Unarchiving Takes Developer Products Offsale

When my place was set to be archived and later unarchived, I noticed that the developer products stopped working and came up as off sale. I cannot find a way to set them to be back on sale. I’m not certain if this has happened to others.

Offsale

This is the place where the developer products are showing as offsale:

Hey FracturedSoftware,

Thank you for reporting this. We’ve tried to reproduce this error but are unable to on our end. Was any other action performed besides Archiving and Unarchiving the game? Any further information would help.

Also, does the price in Robux still show up when you edit these developer products?

Quick questions, did you use any toolbox items?

Nope. I did not use any toolbox items so I’m unsure as to what’s caused it.

I can’t think of any other actions I have done to the place asides updating it. I’ve tried to edit the developer products then apply the changes however they still come up as not on sale. I’m unsure as to what’s causing this and archiving and unarchiving was the first thing I could think of that might be causing this.
I am invoking the transaction client side, is this correct?

What happens when you create a new developer product for this game and prompt purchase for it?

I’m wondering if it’s something specific to your game or the old developer products themselves are now broken.

After creating a new developer product all existing products still shows up as not on sale as well as the new product.

After a DM from @BobaMuncher, turns out I had mistakenly put PromptPurchase instead of PromptProductPurchase. More API information on this function can be found at the following link:
https://developer.roblox.com/en-us/api-reference/function/MarketplaceService/PromptProductPurchase

1 Like