AssemblyLinear/AngularVelocity vs the constraint versions

I have been working for 2+ days non stop on how to create working driving systems for a lifeboat I designed.

I have tried both the physics constraints of Linear Velocity and Angular Velocity as well as the assembly versions. Both bug out and dont end up driving the way it would seem normal to do it. I have visited a lot of different games with mechanics pretty much the same as what I am trying to achieve. I have no idea why or how its doing what its doing. The AssemblyLinearVelocity doesnt even work for me

I really wish I didn’t have to post this as I am well known in my groups for being an excellent coder. I’m lost at this one.

1 Like

Is the linear and angular velocity being controlled by the local player? If not then it should be as the driver has Network ownership over the boat and will override any physics done server side.

The network owner of the assembly is the player controlling the boat, and its still moving around and not in the right direction if that when all the driving values are 0

have you tried using ApplyImpulse and ApplyAngularImpulse

What I recommend is setting the constraint details to visible and then test. You have to go into your model tab to be able to do this.

I usually use this for debugging as you can see the forces and which way their acting.
I find it very helpful for debugging constraints. It’s worth a shot.

been there done that many times, but it still doesnt show why. if you see in the video both constraints were disabled and the boat was still moving in a direction that didnt make any sense given where the linear velocity was pointed.

robloxapp-20230624-1748549.wmv (185.1 KB)

yeah I messed with that for a little bit but I got nothing out of it, even with a huge amount of zeros it wasnt moving which was strange bc I only needed 1000 force for the constraints

1 Like