AssetDelivery web API returns malformed xmlns

When making a get request to{assetId}/version/{version}, either through a C# script or this website Swagger UI, provided all headers are right it returns JSON data with the location of the asset.


When sending another request to the location however, a xml file should return, formatted something like this (depending on the assetType)

However, when I tried to send a get request to the location of this BackAccessory Crowbar - Roblox, I got something like this in return

I’m pretty sure I’m not sending the get request with the necessary headers, but there is little to no information about them, so I don’t really know what to do.

i think new assets have a diff file format

yeah, from what I’ve tried this only seems to happen with UGCs, which are relatively new (perhaps this is a bug?)

In this program I made, everything is fine until it runs into a UGC


non ugcs are in xml & ugcs are in rbxm i think? this is an rbxm reader but it’s in rust GitHub - CraftSpider/rbxm-rs: A Rust implementation for reading/writing roblox models

1 Like

You seem to be right, changing the file extension to rbxm allowed me to open the file in Roblox Studio.

(also after doing some research, turns out non-ugcs are saved as rbxmx, which is basically xml)

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.