Assets failing to load entirely

I was working on an experimental game earlier today, I closed it and re-opened a little while later it to find that nearly all Meshes I’m using from the Library were failing to load. They all keep throwing this main error:

"Mesh Manager: error decoding (Mesh)  contentid '[asset ID]'  exception: Error reading mesh data: unknown version"

Only a few Meshes are successful, but their textures fail to load with the output saying that it couldn’t resolve the texture format. My own meshes work just fine. I’ve re-downloaded Studio, but it’s still occurring.

EDIT: I’ve also been seeing a number of “tag expected after Byte-Order-Mark” errors, which also happens when I try to open the Story Game template (more details below).


I’m getting a lot more errors now, it’s also affecting my own assets but only a few of them. Nearly all textures and sounds are throwing “failed to resolve texture format” and “unknown version” errors which I have never seen before. Originally, I was only having trouble loading meshes, but now it’s affecting all assets. I really need some help with this, it’s starting to hinder development.

This is the result of attempting to insert numerous free Meshes into a new game (note the different error types; two even refused to be inserted; only one or two Meshes actually loaded):

And this is what happens when I try to load the Story Game any template:



The entire decal page and most games are failing to load for me

All of the images are failing to load

Has to be something on Roblox’s end


I still don’t know the extent of this issue (since it doesn’t seem like it affects everyone, at least in the same ways), but it’s still occurring and I’m also experiencing it on my laptop. It may be related to other bugs that have popped up recently, such as free models missing from inventories, but I can’t confirm or deny this.

I would really appreciate if someone could try to look into this, I effectively cannot develop at the moment. Hardly anything that requires an asset ID loads in Studio, including my own clothes when I play test.

I don’t think that issue is related.

You are not alone I have the same problem as you.

this should be renamed w/ URGENT

Totally unable to replicate this issue. Is it only happening on one game for you or any game you edit? It could just be an issue with your internet connection or something. Which assets are you trying to use?

It’s not internet connection. I have tried several different ones and uninstalled/reinstalled roblox. This happens on EVERY game (and on studio). It seems like 25% of meshes/assets load, and the rest do not. (this only started happening a week ago randomly)


The types of errors we’re experiencing don’t suggest that this is being caused by internet connection. It’s only affecting a handful of users, I don’t know what the pattern is yet. It’s affecting me in Studio and in all games.

@AntEverything I’m not sure if I can label this as urgent (even though I agree that it is), I can’t label it as ROBLOXCRITICAL because it doesn’t meet any of the usage criteria.

All I can really guess is that it involves your local Studio install being corrupted or having a broken update. I’d recommend trying it on a different computer if possible and seeing if it works then, as well as totally purging your Studio data (AppData, etc) and then reinstalling it. You could also try logging in with an alt to see if it may be an issue with your account failing to correctly pull assets. I don’t really know what else to suggest

I have already re-installed the current builds of Studio (and the client, for the record) multiple times.

As stated, my laptop (which is also a Mac, running on macOS albeit at an older version) is experiencing the same problems. Seeing as that nothing I’ve done has alleviated this issue at all, I don’t believe anything on my end - that I can fix, anyway - is causing the problem.

I assure you that there is no correlation between these bugs and my account.

I appreciate your insight, but I’d really just like for Roblox to look into this at some point this month.

Not sure if this is related any, but I’m having an issue right now where my game explorer completely fails to load, returning a 500 Internal Server Error. It seems to only be affecting Redshift Arena currently, which is really sad since I only have four days until the holiday / new years featured sort. Everything runs as it should, I just cannot edit anything. Started around 3 days before you made this post and has been occurring ever since.

Is this the same bug where when I try and preload any texture, it displays an error saying “request failed”? If so this is seriously affecting my game

At the moment, assets are loading fine (if not slower than usual) in Studio but I still can’t open template games due to the “tag expected after Byte-Order-Mark” error.

EDIT: I uploaded a Decal and a Mesh yesterday, and while most of my other assets including the new Mesh worked just fine, the Decal was and is still unable to load.

please tell me this is being fixed soon, ive been encountering this problem for days in both studio and in-game :sob:

its a major turn off from developing because i can barely develop due to this bug since i use meshes a lot
also, skyboxes fail to load almost always in every single game i play or edit, and i get the exact same errors as your screenshots

i thought i was going crazy cause i asked around and no one had these problems except for me and someone else but now that a devforum post exists i know for sure that this isnt just a personal problem, so thanks for making a post about this, i appreciate it!

Just gonna check in here to confirm, I’ve been having this issue for a weekish now.

there is no folder named “http” in %localappdata%\Roblox

but there was an http folder i did rename in temp where i did follow your directions earlier

i did that, now my roblox temp folder looks like this

didnt really solve anything, still getting errors

Hi Ashtheking300,
can you please try to manually reset your http cache: go to %TEMP%\Roblox and rename “http” folder there to something else and now try to start studio/client. Do you still see the problems?

(updated incorrect instructions in case others try)