AssetService:CreatePlaceAsync() HTTP 500 Error

Reproduction Steps

Place you can find the bug at:

The template place I am trying to create with CreatePlaceAsync:

The game is owned by this group:

I’m not exactly sure when the issue first occurred but the last created place by users was in January and we have tried to use it since then and it has not been working so I only assume this has been the issue.

Expected Behavior

Create a place based off the template.

Actual Behavior

Throws a HTTP 500 error and fails to create the new place.


No workaround.

Issue Area: Engine
Issue Type: Other
Impact: High
Frequency: Constantly
Date First Experienced: 2022-01-19 00:01:00 (+00:00)
Date Last Experienced: 2022-09-15 00:09:00 (+01:00)
A private message is associated with this bug report


Thanks for the report! We’ll investigate.



Is there any update on this? My game is unplayable while this error persists as players cannot create servers to build inside of. Still receiving the same HTTP 500 error.

I’m more than happy to help investigate this if you reach out.



Thank you! Is there any update on this, or could you tell us more about what could be causing this?

Development on this project has been paused, since this functionality is a core mechanic, but it represents several years of active game development.

Fractured can’t find any causes on our side and the error suggests it is an engine issue. Any help would be much appreciated!


Can we expect a fix to this currently-broken feature?

It’s rather unfortunate that something that could be so useful is sitting being unable to be used. I had a neat game idea I was wanting to utilize CreatePlaceAsync with, but unable to without this feature or doing a hacky workaround.



When would this be fixed?
This bug is very annoying and breaks my game!


Hi there, I’m sorry to hear that this issue was causing issues with your games. Can I check in to see if the endpoint is still having issues?


Hey! Thanks for a response, unfortunately it still appears to be having the HTTP 500 error. :confused: This is the code snippet I use;

local tries = 0
local success, PlaceId = pcall(function() return game:GetService('AssetService'):CreatePlaceAsync("WrollingYou's World #1",13611889713,'test description') end)
if not success then
	repeat wait()
		tries = tries+1
		local success, PlaceId = pcall(function() return game:GetService('AssetService'):CreatePlaceAsync("WrollingYou's World #1",13611889713,'test description') end)
	until success or tries >= 5
if tries >= 5 then
	print('failed to create place')
1 Like

Hi WrollingYou!

Thanks for providing this code snippet. I was wondering if you have the permission enabled for your place.

This checkbox needs to be checked for the endpoint to work correctly.


Thanks for the response!

Yes, both boxes are checked for Create API and Save API.

The template place is within a universe and is not the main starter place – I would imagine that shouldn’t matter that the boxes aren’t checked for the starter place?

Hello, thank you for following up - hopefully this gets resolved and my game can finally be made public again since this is critical to its functionality.

The below screenshot is for the place copied/created (4811622368):

The same also applies to the spawn place in the universe in case it makes any difference however it still does not work.


I keep getting the same error (500) repeatedly. It’s odd because when I join games, most of the stuff in those games doesn’t show up correctly. But the big issue is that my Roblox Studio isn’t working at all. This all started when I was making a big update for my game. Then, for some reason, the studio just stopped working and I got kicked out with the error (500). I lost about half of my work, and I still can’t figure out what’s wrong. I tried to give the project files to a friend, but that didn’t work either. I’ve done a few things like uninstalling and reinstalling Roblox and Roblox Studio, and clearing my computer’s cache, but nothing has helped.

This is a separate issue, 500 is simply the status code provided to any server-side error so your issue is likely unrelated.