Asynchronous Updates broke "Publish to Roblox To..." button

It appears that new (very cool) update which enabled async publishing for solo places has broken the functionality for the “Publish to Roblox to…” button in studio. I was just trying it out seconds ago in my game, and it continued to fail.

My game takes place over multiple universes, and since we need to test with real datastores but don’t want to corrupt the live game file, we keep extra inaccessible places in the universe for testing. I was just updating one of those test places with a fresh copy of the start place when I realized that it wasn’t actually publishing to the test place at all. I still get this in the output

but I wasn’t publishing to that place, I was publishing to a different place in my universe.

I feel like this is hard to explain, so I’ll send a gif of what I’m talking about.

After opening up my test place after publishing, I realized the file was still the old place we had before I did the “publish to roblox to…”, and it had effectively done nothing. I tried to go into detail but if there are questions let me know.

Edit: quick note, the game is a group-owned team create.


Hey, we saw this in another post. We will be turning this feature off soon as we can.


Async Publishing is now turned off. Please restart Studio and verify that this is resolved.

It appears to publish, but immediately after publishing I get this

Clicking Reconnect scrambles the menu and crashes studio, tried it twice and it happened both times.

Edit: I’m going to see if it actually did publish right now.

Edit 2: It looks like it did, so aside from disconnecting and crashing after publishing to the other place, it works :ok_hand:

So, you crashed twice when attempting to publish? This was the case even after a full Studio restart?

Yes, although it did publish successfully. It’s just that right after that it crashed.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.