At night, Atmosphere objects flatten shadowed normal maps

With a PBR lighting setup (EnvironmentSpecularScale and EnvironmentDiffuseScale both set to 1, and Ambient/OutdoorAmbient both set to 0) and an Atmosphere object present in Lighting, any geometry that has a shadow cast upon it by other geometry will cause the normal map of its material to render incorrectly, regardless if the Atmosphere is even enabled. The issue does not occur during the daytime.

This is clearly unintended behavior.
Side note: I don’t believe the full PBR lighting setup is required for this to occur, but it makes it the most noticeable.

Here is an image demonstrating the issue, and the place file the screenshots were captured in.

Repro_AtmosphereSurfaceNormals.rbxl (32.7 KB)

Other side note: Atmospheres also seem to interfere with the placement of stars in the sky.


If you have haze set it appears to work correctly, or at least better.

1 Like

It still seems to flatten normal maps substantially unless you set the haze color to pure white, in which case the flattening is negligible. However, it isn’t always preferred to have atmospheric haze enabled. Sometimes I just want the fog and not the skybox haze.

1 Like

Thanks for the report! We’ve filed a ticket to our internal database and we’ll follow up when we have an update for you.


I’ve also noticed this somewhat in reverse.

When light is shined on a lot of PBR surfaces, it seems to become flat, but when I look on the opposite side (where no light exists), there’s PBR surfaces. My Surfaces look fine in blender and other engines as well.