Attempting to teleport to a place created under main game?

  1. What do you want to achieve? Keep it simple and clear!

Im basically making a story game and i need the players to be teleported to the main game.

  1. What is the issue? Include screenshots / videos if possible!

I havent used “Places” since 2020 so im not really sure if im just a bit rusty or what :face_with_raised_eyebrow:?

Lets get to the problem. When i try to teleport to the main game created with the asset manager i get the error “That place is restricted”. Yes i have Allow third party teleports enabled n all that stuff. Heres the code that handles the teleporting:


local function Teleport(List) -- // List is an array of all the players obviously
	local Options ="TeleportOptions")
	Options.ShouldReserveServer = true
	game["Teleport Service"]:TeleportAsync(10629870256,List,Options) -- // Id is the place created with the asset manager
  1. What solutions have you tried so far? Did you look for solutions on the Developer Hub?

And yes before someone tells me “Look on the dve forum before postin”. I have done that already but cant find anything thats useful for me!. I also tried lookin at the dev hub if i was using “TeleportAsync” wrong but im not… Im not really sure what im doing wrong so itd be pretty awesome if anyone could help me :grinning: :grinning:

Have you published the starting place and made it public? Studio also doesn’t allow TeleportService in studio

Ah it had to be public. My bad :sweat_smile: i havent used them for some years like i said . ANyways thanks for the help it means alot :slightly_smiling_face:

1 Like