Auto-complete Issue

I just updated studio and I’m experiencing a super annoying issue with auto-complete. Whenever I start typing something and auto-complete comes up, it automatically stops me from typing and instead starts selecting options from the auto-complete menu based on the keys I’m pressing.

As you can see, it stops me from typing and I have to use my mouse to re-focus it on the line in order to continue.

11 Likes

I just started experiencing a similar issue where, whenever I try to type a function such as :Connect() or :Wait() it prevents me from typing. only fix is to type It somewhere else then copy paste which is mighty inconvenient

https://gyazo.com/c45bcb2350bc127ac8242ac676de7265 , I am still typing, even after it stops on screen

1 Like

We are looking into this, thanks for the report.

6 Likes

This is happening to me too! I was hoping to get some coding done today but it is taking forever due to this bug.

My OS is Mac OS X Catalina and I am on a 2015 macbook pro. I hope this helps

Yes, this is very bad on the Mac OS - it just started happening since the update… I had to turn AutoComplete off, but that’s been inconvenient, as well.

Basically, tab completion doesn’t work, hitting enter to choose the possible choice doesn’t work, and the dropdown doesn’t go away, if you keep typing. You have to click the right choice or click the mouse focus back in the script window to regain control.

Yea exactly. I’m also on Mac OS Sierra. This might be a problem only on Macs

I’m experiencing the same issue, it is making development very difficult. I’m on macOS 10.14 (Mojave)

1 Like

Happening to me too high sierra 10.13.6

I’m determined, I have a lot of scripting to do lol

Same is happening to me as well. MacOS Catalina. Working fine before the most recent update. Very frustrating.

I’m on macOS 10.14.6 and getting this same issue. The cursor loses focus without fail when accessing a user-defined variable or roblox function. There are no issues when studio suggests autocomplete when accessing children.

Experiencing this as well. It only started recently for me (within the last hour), a short while after updating Studio (it didn’t seem to happen immediately after the update, but I may have just not noticed). Hoping it can be resolved soon as it has abruptly made it very difficult to work.

1 Like

I am having the same issue. This is so frustrating I am trying to get work done, but I can’t without getting annoyed.

Just ran into the same issue when I intended to get some work done. Good to know the staff is already aware of it. Running macOS Mojave 10.14.6.

It just started happening to me as well. If I close studio and restart, it is okay for a few minutes. I have tried turning my internet off and nothing seems to help. I am hoping there is a way to disable this feature in studio so I can get work done.

edit
I have disabled auto-complete for now.

I hope they are still looking into this. I turned auto-fill off for now

.

It feels like turning off auto-complete also fixed typing delays that used to happen

We’ve identified the issue, but will not be able to fix it until Monday.

Until then, if you view RobloxStudio in the finder and click Show Package Contents, you can fix this by creating a folder called ClientSettings in Contents/MacOS and inserting the following file:

ClientAppSettings.json (55 Bytes)

You can remove the ClientSettings folder when we fix this on Monday, or it will be automatically removed whenever Studio updates next.

3 Likes

This happens to me also, I figured it was a personal thing but I guess it’s not just me. Super annoying.

I just installed Studio again after a while, and I thought this was new functionality. :man_facepalming::man_facepalming:

image

The ClientSettings file above has fixed the issue for me.

This fix may have fixed the issue, however it breaks autocomplete, i’m only getting built in functions show up, this is pretty much just disabling autocomplete and still making it irritating to write code.

Also just found it still occurring: